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ApSIC Xbench allows you to organize and search your bilingual 

reference terminology. ApSIC Xbench also features several Quality 

Assurance (QA) checks to boost the quality of your translations. 

Search features 
ApSIC Xbench allows you to perform powerful searches on the following 

bilingual formats: 

 Tab-delimited text files (*.txt, *.tsv, *.utx) 

 XLIFF files, including memoQ XLIFF, Memsource XLIFF, Idiom 

XLIFF, Translation Workspace XLIFF, XTM XLIFF, and other 

flavors of XLIFF (*.xlf, *.xlif, *.xliff, *.xlz, *.mqxlz, *.mxliff) 

 TMX memories (*.tmx) 

 TBX/MARTIF glossaries (*.xml, *.tbx, *.mtf) 

 TIPP files (*.tipp) 

 Trados exported memories (*.txt) 

 Trados exported MultiTerm 5 glossaries (*.txt) 

 Trados MultiTerm glossaries (*.xml, *.sdltb, *.mdb) 

 Trados TagEditor files (*.ttx) 

 Trados Word uncleaned files (*.doc, *.rtf) 

 Trados Studio files (*.sdlxliff, *.sdlproj) 

 Trados Studio memories (*.sdltm) 

 memoQ files, including hand-off and hand-back packages (*.mqxlz, 

*.mqxliff, *.mqout, *.mqback) 

 memoQ termbases in CSV format  

 SDLX ITD files (*.itd). Note: This option requires that SDLX is 

installed on the machine.  

 SDLX memories (*.mdb) 

 STAR Transit 2.6/XV/NXT directories 

 PO files (*.po) 

 IBM TranslationManager exported dictionaries (*.sgm) 

 IBM TranslationManager installed and exported folders (*.fxp)  

 IBM TranslationManager exported memories (*.exp) 

 OpenTM2 exported dictionaries (*.sgm) 

 OpenTM2 installed and exported folders (*.fxp)  

 OpenTM2 exported memories (*.exp) 

Overview 
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 Wordfast memories (*.txt) 

 Wordfast glossaries (*.txt) 

 Wordfast Pro files (*.txml, *.txlf) 

 Déjà Vu X/Idiom files, including Satellite and Pack&Go (*.wsprj, 

*.dvprj, *.dvsat, *.dvpng) 

 Déjà Vu X/Idiom memories (*.wstm, *.dvmdb) 

 Déjà Vu X/Idiom termbases (*.wstb, *.dvtdb) 

 Logoport RTF files (*.rtf) 

 Microsoft software glossaries (*.csv) 

 Mac OS X glossaries (*.ad, *.lg) 

 Qt Linguist files (*.ts) 

 Passolo glossaries (*.glo) 

 Transifex projects 

 Matecat jobs 

 Remote Xbench Server glossaries 

Reference terminology can be organized in several levels of priority to 

show clearly to translators the particular translation project preferences.  

ApSIC Xbench runs on the background and can be invoked to search for 

the currently marked text using a system-wide key combination (by 

default, Ctrl+Alt+Insert). This effectively provides instant terminology 

searches from within any Windows application using a common key 

combination. 

ApSIC Xbench features a very powerful search engine. Not only can you 

search by source or target text but also perform negative or conditional 

searches with the PowerSearch function (Ctrl+P) or perform complex 

searches using either regular expressions or Microsoft Word wildcards.  

Note: After it is launched, ApSIC Xbench stays on the background until it 

is explicitly closed with the Shut Down Xbench command that is 

available either by right-clicking the icon on the Windows task bar or 

using the Project pull-down menu.  

QA features 
By defining your current translation files as ongoing translation in your 

ApSIC Xbench project, you can run the following QA checks: 

 Find untranslated segments 

 Find segments with the same source text and different target text 

 Find segments with the same target text and different source text 

 Find segments whose target text matches the source text (potentially 

untranslated text) 

 Find tag mismatches 
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 Find number mismatches 

 Find URL mismatches 

 Find alphanumeric mismatches 

 Find unpaired symbols (i.e. unpaired parentheses, square brackets, or 

braces) 

 Find unpaired quotes 

 Find double blanks 

 Find repeated words 

 Find UPPERCASE words in the source text without a match in the 

target text and UPPERCASE words in the target text without a match 

in the source text 

 Find CamelCase words in the source text without a match in the 

target text and CamelCase words in the target text without a match in 

the source text  

 Find terminology mismatches against a list of key terms 

 Execute user-defined checklists. 

 Spell-check translations (requires downloading the language 

dictionary with Tools->Spell-Checking Dictionaries) 

Checklists are user-defined searches that you can run in batch against 

your ongoing translation. For example, with checklists you can search for 

banned words or typical translator pitfalls. 

 





 

 7 
 

Installing and Uninstalling 
ApSIC Xbench 

 

To install ApSIC Xbench 
ApSIC Xbench 3.0 is available in 32-bit and 64-bit editions. The 32-bit 

edition can be installed on 32-bit and 64-bit Windows machines. The 64-

bit edition can only be installed on 64-bit machines. ApSIC Xbench is 

supported on Windows XP, Windows Vista, Windows 7, and Windows 8. 

It is also supported on Windows 2003 and Windows 2008. 

To install ApSIC Xbench, please do the following: 

Run the installation executable (for example, 

Setup.Xbench.x64.3.0.1080.exe). The installer welcome screen will 

appear. 
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Click Next. The license window appears. Please read carefully the license 

information to ensure you accept its terms. 

If the terms of the license are acceptable to you, please click I Agree. If 

they are not acceptable please click Cancel. 

 

Change the destination folder if necessary and click Install to continue. 

Files are copied to the selected destination and the following window 

appears. 

 

Click Finish to close the Window and start using ApSIC Xbench. 

A link to the ApSIC Xbench executable is installed on the Start-

>Programs->ApSIC Tools->Xbench path, together with the 

documentation. 
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To uninstall ApSIC 
Xbench 

To uninstall ApSIC Xbench, please do the following: 

1 Choose Start->Settings->Control Panel on the Windows task bar. 

Go to the Windows Control Panel and open the Add/Remove 

Programs icon. 

2 Look for ApSIC Xbench 3.0 in the list and click the Change or 

Remove button. 

3 When you receive a confirmation message, click Yes. 

Unattended Installation 
You can perform an unattended installation of ApSIC Xbench using the 

/S switch from the command line. 

c:\>Setup.Xbench.x64.3.0.exe /S 

If you wish to specify a different installation directory, you can do so 

using the /D switch. 

c:\>Setup.Xbench.x64.3.0.exe /S 

/D=[install_directory_path] 

Please note that the /S and /D switches are case-sensitive! 
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Launching and Shutting 
Down ApSIC Xbench 

ApSIC Xbench is an application that, once launched, must be explicitly 

shut down when it is no longer needed. In a normal scenario, you will 

load your reference project to search for terminology while you are 

translating and leave it in the background until you finish your translation 

work. Closing the ApSIC Xbench window does not remove the program 

from the memory because it is waiting for your next query with the 

Ctrl+Alt+Insert key sequence. 

Launching ApSIC Xbench 
To launch ApSIC Xbench, follow one of these procedures: 

 Choose Start->Programs->ApSIC Tools->Xbench on the Windows 

task bar. 

 Double-click on the icon of a previously defined ApSIC Xbench 

project (.xbp extension). 

Shutting Down ApSIC 
Xbench 

In order to shut down ApSIC Xbench, you have the following options: 

 Right-click the ApSIC Xbench icon (a pink gem) located in the 

system tray and click Shut Down Xbench. 

 On the Project menu, click Shut Down Xbench. 
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Signing Up for ApSIC 
Xbench 

ApSIC Xbench licensing system requires that users sign up with their 

email. When you first start Xbench, a Sign In dialog will appear. 

 

If you do not have yet an Xbench account, you need to sign up to create 

one. Click the Sign Up link in the Sign In window to expand it with the 

fields for the sign up. 

 

Type your email and password twice and click Sign Up for Xbench. 

In a few seconds, you will receive a verification email in your email 

inbox. Open the email item and click the Verify your email address 

link. 

Now you are able to sign in with your newly created credentials. 
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In this section you will learn about ApSIC Xbench search features. The 

following concepts are useful to understand how ApSIC Xbench works: 

Project: In ApSIC Xbench, a project is a definition of files and their 

priorities and relationships. The first thing you do in ApSIC Xbench is to 

define a project that includes the terminology you want to search -- and 

how to search it. 

Ongoing translation: ApSIC Xbench lets you mark a file or set of files as 

"ongoing translation" to visually identify its strings in the search results. 

In addition, QA features can be performed only on files defined as 

ongoing translation. 

Checklist: In ApSIC Xbench, a checklist is an array of searches that can 

be run in batch. 

PowerSearch: This is a special search mode where you can define 

AND/OR conditions and negations to the search string to perform 

complex searches. This is a very useful feature for QA-related activities. 

Regular Expression: A regular expression is a search string that contains 

special characters with specific meanings that allow you to provide a 

concise and flexible means to identify patterns of characters and words. 

The grammar of regular expressions follows industry standards. This is 

one of ApSIC Xbench search and QA modes. 

Microsoft Word Wildcard: ApSIC Xbench also allows you to perform 

searches using Microsoft Word wildcards, which follow a grammar 

similar to regular expressions but normally in a simplified alternative 

syntax. 

  

 

Working with Search Features 
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Defining Search Projects 
The first step to use the powerful search features of ApSIC Xbench is to 

define the reference material for your project. To do so, add the relevant 

files and directories into your project by choosing Project->Properties 

or pressing F2. The Project Properties dialog appears as illustrated 

below. 

 

Click the Add button to add files to your project. 

Select the type of file that you will be adding to the ApSIC Xbench 

project: 
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ApSIC Xbench supports the following file types: 

 Tab-delimited Text File (*.txt, *.tsv, *.utx). A file where every line 

consists of a number of fields delimited with the tab character. The 

first and the second fields of an entry are assumed to be the source 

and the target texts respectively. The additional fields are assumed to 

be descriptive and there can be any number of them. Tab-delimited 

UTX files are also supported with this format. 

 XLIFF File (*.xlf, *.xlif, *.xliff, *xlz, *.mxliff, *.mqxlz). A file compliant 

with the XLIFF specification. 

 TMX Memory (*.tmx). A file compliant with the TMX specification. 

Most translation tools are capable of generating TMX memories of 

varying compliance levels. 

 TBX/MARTIF Glossary (*.xml, *.tbx, *.mtf). A file compliant with the 

TBX or the MARTIF specification. 

 TIPP File (*.tipp). A file compliant with the TIPP specification. 

 Trados Exported Memory (*.txt). A Trados memory in .txt format as 

exported from Trados. 

 Trados Exported MultiTerm 5 Glossary (*.txt). A MultiTerm glossary 

exported into a .txt file where each entry is delimited with a line 

containing two asterisks (**). 

 Trados MultiTerm Glossary (*.xml, *.sdltb, *.mdb). A MultiTerm 

glossary exported in XML, SDLTB, or MDB format. 

 Trados TagEditor File (*.ttx). A Trados .ttx file. 

 Trados Word File (*.doc, *.rtf). A Trados .doc or .rtf file with bilingual 

segments. 

 Trados Studio File (*.sdlxliff, *.sdlproj). A Trados Studio .sdlxliff or 

.sdlproj file. When a Trados Studio project file (*.sdlproj) is 

specified, ApSIC Xbench opens the .sdlxilff files pointed by the 

project file for the first language pair found in the project file. 

 Trados Studio Memory (*.sdltm). A Trados Studio Translation Memory 

in .sdltm format. 

 memoQ File. A memoQ XLIFF file with .mqxlz or .mqxliff extension, 

a memoQ hand-off file (*.mqout), a memoQ hand-back file 

(*.mqback), or a memoQ termbase file (*.csv). 

 SDLX File (*.itd). An SDLX .itd file. Note: This option requires that 

SDLX is installed on the machine.  

 SDLX Memory (*.mdb). An individual SDLX .mdb file containing a 

translation memory. 

 STAR Transit 2.6/XV/NXT Directory. A directory that contains Transit 

language pairs. 

 PO File. A bilingual .po file, normally generated with gettext. 

 IBM TM/OpenTM2 Dictionary (*.sgm). An IBM TranslationManager or 

OpenTM2 dictionary in SGML format. This file has the .sgm 

extension. 
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 IBM TM/OpenTM2 Folder. An IBM TranslationManager or OpenTM2 

folder installed on your system. This format can be defined as 

ongoing translation to clearly distinguish the new and the old 

translation and also to display the untranslated segments to make 

better decisions for new terminology. 

 IBM TM/OpenTM2 Exported Folder (*.fxp). An IBM 

TranslationManager or OpenTM2 folder exported in .fxp format. 

 IBM TM/OpenTM2 Exported Memory (*.exp). An IBM 

TranslationManager or OpenTM2 memory exported in .exp format. 

 Wordfast Memory (*.txt). A Wordfast memory, with the .txt extension. 

 Wordfast Glossary (*.txt). A Wordfast glossary, with the .txt 

extension. 

 Wordfast Pro TXML (*.txml, *.txlf). A Wordfast Pro bilingual file, with 

the *.txml or *.txlf extension. 

 Déjà Vu X/Idiom File (*.wsprj, *.dvprj, *.dvsat, *.dvpng). A Déjà Vu or 

Idiom database of project translation files, with extensions .dvprj, 

.dvsat, .dvpng, or .wsprj. 

 Déjà Vu X/Idiom Memory (*.wstm, *.dvmdb). A Déjà Vu or Idiom 

translation memory, with extensions .dvmdb or .wstm. 

 Déjà Vu X/Idiom Termbase (*.wstd, *.dvtdb). A Déjà Vu or Idiom 

termbase, with extensions .dvtdb or .wstb. 

 Logoport RTF (*.rtf). An individual Logoport .rtf file or a directory 

containing Logoport .rtf files. 

 Microsoft Glossary (*.csv). A Microsoft software glossary, made 

publicly available by Microsoft via MSDN and containing all the 

strings of a Microsoft software application. 

 Mac OS X Glossary (*.ad, *.lg). A file in Apple's XML format for 

software, freely downloadable from the Internet. 

 Qt Linguist Files (*.ts). A file in the translation format for the Qt 

framework. 

 Passolo Glossaries (*.glo). A Passolo glossary, with extension *.glo.  
 Transifex Project. An online Transifex project. 

 Matecat Job. An online Matecat job, both from www.matecat.com or 

self-hosted. 

 Remote Xbench Server. A reference to a Remote ApSIC Xbench 

Server. 

After the file type is selected, the File List tab appears where you can add 

multiple entries of the selected type. Depending on the file type chosen, 

click on the Add File... or Add Folder... button to add entries to the list. 

From this point, the sequence of displays may differ depending on the 

selected file type. Follow the instructions corresponding to the specific 

file type for the exact steps. 
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If you are adding a ... Follow these steps: 

Tab-delimited text file, XLIFF 

file, TMX memory, TIPP file, 

Trados Exported memory, 

Trados Tag Editor file, Trados 

Word file, Trados Studio file, 

Trados Studio memory, memoQ 

file, SDLX file, SDLX Memory, 

PO file, IBM TM/OpenTM2 

Dictionary, IBM TM/OpenTM2 

Exported folder, IBM 

TM/OpenTM2 Exported 

memory, Wordfast memory, 

Wordfast glossary, Wordfast Pro 

TXML/TXLF, Microsoft 

glossary, Mac OS X glossary, 

Déjà Vu X/Idiom file, Déjà 

Vu/Idiom memory, Déjà 

Vu/Idiom termbase, Logoport 

RTF file, Qt Linguist file, 

Passolo glossary 

1 The File List tab appears. Click 

Add File or Add Folder to add files 

or folders of files from the selected 

type. Folders will appear on 

boldface in the list. 

2 Click Next on the File List tab to 

get to the Properties tab. 

3 Assign the properties relevant and 

click OK to finish. Note: If you 

added any folder in step 1, click 

Next to get to an additional panel 

where you indicate if you wish to 

include files of the same type in 

child folders with the Recurse 

Directories check box. 

STAR Transit directory 1 After the File List tab appears, 

opening automatically the Select 

Directory.. dialog. Navigate to the 

directory that contains the files you 

wish to load into the ApSIC Xbench 

project. 

2 Click Next on the File List tab to 

get to the Properties tab. 

3 Assign the properties relevant to the 

directory and click Next to get to 

the Directory Settings tab. 

4 In the Directory Settings tab you 

can check the Recurse Directories 

check box to have ApSIC Xbench 

search also subdirectories for files. 

Trados exported MultiTerm 5 

glossary, Trados MultiTerm, or 

TBX/MARTIF 

1 The File List tab appears, opening 

automatically the Add Glossary 

dialog. Select all the files of the 

current type in this window. If you 

need to pick up more files from 

another directory, when you are 

again in the File List tab, click the 

Add File button to open again the 

Add Glossary window. 

2 Click Next on the File List tab to 

get to the Properties tab. 

3 Assign the properties relevant to the 

file and click Next to get to the tab 
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corresponding to the file format. 

4 Select the source and the target 

language from the list of languages 

offered and click OK to finish. 

IBM TM/OpenTM2 Folder 1 After the File List tab appears, 

opening automatically the Select 

IBM TM/OpenTM2 Folder dialog. 

If necessary, change to the drive 

containing your IBM TM or 

OpenTM2 folder and then select the 

folder or folders in the list of folders 

that appears. 

2 Click Next on the File List tab to 

get to the Properties tab. 

3 Assign the properties relevant and 

click OK to finish. 

Transifex Project 1 Assign the properties relevant and 

click Next to get to the Transifex 

tab. 

2 Type a Transifex project slug or 

paste the URL of a Transifex project 

and then click Connect. 

3 Choose a language from the list of 

languages of the project and click 

OK. 

Matecat Job 1 Assign the properties relevant and 

click Next to get to the Matecat tab. 

2 Paste in Matecat URL the URL 

that appears in the browser when 

you open the Matecat job in the 

Matecat online editor. 

Remote Xbench Server 1 Assign the properties relevant and 

click Next to get to the Remote 

Xbench Server tab. 

2 Assign a name for the connection 

and specify the URL of the Xbench 

Server. 

Once you are returned to the Project Properties window, you can add 

other files or directories following the steps described above. 

When you are done, click OK on the Project Properties window to 

return to ApSIC Xbench main window. ApSIC Xbench will load the 

glossaries into the work environment. 
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At this time, on the Project menu, click Save as to save the newly 

created project in your directory with other ApSIC Xbench projects. It is 

recommended to save project files with meaningful names for later reuse.  

Note: The next time ApSIC Xbench is started, it will automatically load 

the previous project unless this feature is disabled in Tools->Settings-

>Miscellaneous. 
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Searching for Terms 
ApSIC Xbench has a very powerful search engine. For example, you can 

search by source term, target term, or both source and target term. ApSIC 

Xbench also allows you to search using regular expressions or Microsoft 

Word wildcards, and combine them using the PowerSearch mode. 

 

Likely, most of your searches will be done by source term. However, 

your need to search for a term will not originate while you are in the 

interface of ApSIC Xbench, but when you are translating within Word or 

within some other CAT application such as Trados Studio, memoQ, 

Wordfast, Déjà Vu, or from a note in your email program such as 

Microsoft Outlook. 

This is why ApSIC Xbench is accessible system-wide from any 
application with a single key combination (Ctrl+Alt+Insert). 

The following 5 steps describe how you should interact with ApSIC 

Xbench. The starting point for this scenario is an open document with 

Microsoft Word in the foreground and an ApSIC Xbench project loaded 

in the background. 

1 In Microsoft Word, highlight the term (totally or partially) that you 

want to search for.  

2 In Microsoft Word, press Ctrl+Insert and then Ctrl+Alt+Insert to call 

ApSIC Xbench. This action automatically searches the files loaded 

into ApSIC Xbench for the marked term. This sequence of keys will 

be the most important one for you when using ApSIC Xbench for 

searching for terminology.  
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3 ApSIC Xbench presents the results of the query as illustrated in the 

figure above. 

You can have up to three priority areas, one in green (high priority), 

one in maroon (medium priority), and one in blue (low priority). The 

column labeled # provides a count of all the occurrences in the file 

that have been grouped for the entry shown on the window. 

The green bullet  next to the Target term indicates that the entry is a 

full exact match (case sensitive) with the search string. If a yellow 

bullet  appears next to a Target term, it means that the entry is a full 

match except for the case. For example, if in the above example we 

had searched for “Clipboard” instead of “clipboard”, the bullets 

would have been green instead of yellow because the case of the 

query string would match exactly the case of the string that is found 

in the file (Clipboard). 

When translating documentation, this indication is very useful 

because you can copy-and-paste the target term, which makes you 

more productive and accurate. The following steps describe how to 

benefit from this. 

4 If you want to copy the target term of the currently selected entry into 

the clipboard, just press Enter to close the ApSIC Xbench window. 

ApSIC Xbench is hidden and you are returned to the calling 

application (in this example, Microsoft Word). 

Note: If you do not want to copy anything to the clipboard, press Esc 

or Alt+F4 to hide ApSIC Xbench and return to Microsoft Word. 

5 If you opted to close the ApSIC Xbench window with the Enter key, 

thus saving the target term in the clipboard, you can press Shift+Insert 
to copy the target term into your document. 

You will notice that, especially for software options, it is faster to search 

and paste than to type the target software options manually. Thus, you are 

more productive and your translations are more consistent at the same 

time. 

Tip: Familiarize yourself with the above procedure until you feel it is 

intuitive enough. Try it with words that you know are exact matches so 

you can get familiar with the paste step. 
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Regular Expressions and 
Microsoft Word Wildcards 

ApSIC Xbench allows you to perform powerful searches using regular 

expressions or Microsoft Word wildcards. To activate these search 

modes, do the following: 

1. Choose View->Search Options to show the Search Options pane. 

2. Expand the Search Mode drop-down and choose Regular 

Expressions or MS Word Wildcards. 

3. You will notice that an icon will appear next to the Source Term and 

Target Term fields to indicate that you are in the selected mode. 

Regular Expressions Syntax 
Character or 
Expression 

Meaning Examples 

. Any character Jo.n matches John and Joan, but does not 

match Johan. 

* 0 or more instances of the preceding 

character 

Joh*n matches Jon, John, and Johhn, but does 

not match Johan. 

Note: In Regular Expressions, the asterisk does 

not have the same behavior as in Microsoft 

Word wildcards. To mean any number of 

characters you need to use the dot-asterisk 

sequence (.*). For example, Joh.*n matches 

John, Johhn, and Johan (but does not match 

Jon). 

? 0 or 1 instances of the preceding 

character 

Joh?n matches Jon and John, but does not 

match Johan. 

+ 1 or more repetitions of the 

preceding character 

Joh+n matches John, and Johhn, but does not 

match Jon or Johan. 

{m} Exactly m repetitions of the 

preceding character 

Joh{2}n matches Johhn, but does not match 

Jon, John or Johhhn. 

{m,} m or more repetitions of the 

preceding character 

Joh{2,}n matches Johhn and Johhhn, but does 

not match Jon or John. 
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{,n} 1 to n repetitions of the preceding 

character 

Joh{,2}n matches John and Johhn, but does 

not match Jon or Johhhn. 

{m,n} m to n repetitions of the preceding 

character 

Joh{1,2}n matches John and Johhn, but does 

not match Jon or Johhhn. 

< Start of word <Phon matches Phone but does not match 

iPhone. 

> End of word hones> matches Phones but does not match 

Phone. 

Note: To match a whole word, you can specify 

<Phone> to match Phone, but not Phones or 

iPhone, or you can specify <Phones*> to match 

both Phone and Phones, but not iPhone or 

iPhones. 

^ Start of line (needs to be at the 

beginning of the expression) 

^Phone will match all units that start with 

Phone. 

$ End of line (needs to be at the end of 

the expression) 

received$ will match all units that end with 

received. 

\ Escape character. The character 

following it is parsed as a simple 

character. 

phone\. will match all units that have a period 

after phone. (In this case, the dot does not mean 

"any character" because it is escaped). 

% Make the preceding character or 

expression case-insensitive. When 

ApSIC Xbench search mode is case-

sensitive, this modifier can be used 

to make part of the search string 

case-insensitive. 

In ApSIC Xbench case-sensitive mode, a% will 

match a and A. Similarly, P(hone)% will match 

Phone and PHONE, but will not match phone 

because in the latter case, the letter p is not 

included in the expression affected by the 

modifier. 

\xnn or \xnnnn  The character specified by nn or 

nnnn, where nn or nnnn is a 

hexadecimal number. If only two 

digits are specified, it is assumed to 

be its Unicode equivalent \x00nn. 

\x48\x6f\x77\x64\x79\x3f and 

\x0048\x006f\x0077\x0064\x0079\x003f both 

match Howdy? 

| OR operator ^(H|I) matches all sentences that start with an H 

or that start with an I. 

( ) Parenthesis operator to specify 

priority 

(^H)|I matches all sentences that start with an H 

or that contain an I. 
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[set-expression] One character belonging to the set 

defined by set-expression. A set is 

defined by individual characters (for 

example, [aeiou]) and/or by ranges 

of characters specified by the starting 

and the ending character (for 

example, [a-z]). 

File[0-9] matches File0, File1, File2, ... File9, 

but does not match FileX. 

File[ABC] matches FileA, FileB and FileC, but 

does not match FileD. 

[:special-set:] One character belonging to a 

predefined special-set. The following 

special sets are predefined In ApSIC 

Xbench: [:space:], [:control:], 

[:punctuation:], [:punct:], 

[:separator:], [:sep:], [:symbol:], 

[:alpha:], [:num:], [:xdigit:], 

[:alphanum:], [:letter:], [:digit:], 

[:letterdigit:], [:number:]. Special set 

must be used within set-expressions 

(for example [:digit:]). The 

characters matched by each special-

set are listed in Special Sets (on page 

31). 

File[:digit:] matches File0, File1 or File2, but 

does not match FileA or FileB. 

File[:alpha:][:digit:] matches FileA0, FileB1 

or FileC2, but does not match File1A or File2B. 

[^set-
expression] 

Any character not belonging to the 

set-expression. 

File[^ABC] matches FileD or FileE, but does 

not match FileA, FileB and FileC. 

(expression)=n Assigns to variable n the resolved 

value of the expression in the 

currently parsed segment. The 

resolved value can be recalled with 

the expression @n. 

(File[0-9])=1 defines variable 1 as the resolved 

value of File[0-9]. 

@n Renders the resolved value of 

variable n. 

@1 in the example above would resolve to 

string File1 if the string searched contains File1, 

File2 if it contains File2, and so on. 
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Microsoft Word Wildcards Syntax 
Character or 
Expression 

Meaning Examples 

. Any character Jo.n matches John and Joan, but does not 

match Johan. 

* 0 or more characters Joh*n matches John, Johan and Johhn, but 

does not match Jon. 

? 0 or 1 characters Jo?n matches Jon, John and Joan, but does not 

match Johan. 

@ 1 or more repetitions of the 

preceding character 

Joh@n matches John, and Johhn, but does not 

match Jon or Johan. 

{m} Exactly m repetitions of the 

preceding character 

Joh{2}n matches Johhn, but does not match 

Jon, John or Johhhn. 

{m,} m or more repetitions of the 

preceding character 

Joh{2,}n matches Johhn and Johhhn, but does 

not match Jon or John. 

{,n} 1 to n repetitions of the preceding 

character 

Joh{,2}n matches John and Johhn, but does 

not match Jon or Johhhn. 

{m,n} m to n repetitions of the preceding 

character 

Joh{1,2}n matches John and Johhn, but does 

not match Jon or Johhhn. 

< Start of word <Phon matches Phone but does not match 

iPhone. 

> End of word hones> matches Phones but does not match 

Phone. 

Note: To match a whole word, you can specify 

<Phone> to match Phone, but not Phones or 

iPhone, or you can specify <Phones*> to match 

both Phone and Phones, but not iPhone or 

iPhones. 

^ Start of line (needs to be at the 

beginning of the expression) 

^Phone will match all units that start with 

Phone. 

$ End of line (needs to be at the end of 

the expression) 

received$ will match all units that end with 

received. 

\ Escape character. The character 

following it is parsed as a simple 

character. 

phone\. will match all units that have a period 

after phone. (In this case, the dot does not mean 

"any character" because it is escaped). 
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\xnn or \xnnnn The character specified by nn or 

nnnn, where nn or nnnn is a 

hexadecimal number. If only two 

digits are specified, it is assumed to 

be its Unicode equivalent \x00nn. 

\x48\x6f\x77\x64\x79\x3f and 

\x0048\x006f\x0077\x0064\x0079\x003f both 

match Howdy? 

| OR operator ^(H|I) matches all sentences that start with an H 

or that start with an I. 

( ) Parenthesis operator to specify 

priority 

(^H)|I matches all sentences that start with an H 

or that contain an I. 

[set-expression] One character belonging to the set 

defined by set-expression. A set is 

defined by individual characters (for 

example, [aeiou]) and/or by ranges 

of characters specified by the starting 

and the ending character (for 

example, [a-z]). 

File[0-9] matches File0, File1, File2, ... File9, 

but does not match FileX. 

File[ABC] matches FileA, FileB and FileC, but 

does not match FileD. 

[:special-set:] One character belonging to a 

predefined special-set. The following 

special sets are predefined In ApSIC 

Xbench: [:space:], [:control:], 

[:punctuation:], [:punct:], 

[:separator:], [:sep:], [:symbol:], 

[:alpha:], [:num:], [:xdigit:], 

[:alphanum:], [:letter:], [:digit:], 

[:letterdigit:], [:number:]. Special set 

must be used within set-expressions 

(for example [:digit:]). The 

characters matched by each special-

set are listed in Special Sets (on page 

31). 

File[:digit:] matches File0, File1 or File2, but 

does not match FileA or FileB. 

File[:alpha:][:digit:] matches FileA0, FileB1 

or FileC2, but does not match File1A or File2B. 

[!set-expression] Any character not belonging to the 

set-expression. 

File[!ABC] matches FileD or FileE, but does 

not match FileA, FileB and FileC. 

(expression)=n Assigns to variable n the resolved 

value of the expression in the 

currently parsed segment. The 

resolved value can be recalled with 

the expression \n. 

(File[0-9])=1 defines variable 1 as the resolved 

value of File[0-9]. 

\n Renders the resolved value of 

variable n. 

\1 in the example above would resolve to string 

File1 if the string searched contains File1, File2 

if it contains File2, and so on. 
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Special Sets 
The following table shows the characters that are matched by the special 

sets that can be used in regular expressions and Microsoft Word wildcard 

characters: 

Special Set Characters matched by the special set 

[:alpha:] Any of the characters considered as alphabetic by the 

operating system under the current ANSI code page. 

[:alphanum:] Any of the characters considered as alphanumeric by 

the operating system under the current ANSI code 

page. 

[:control:] Characters in the hexadecimal range 0x00-0x19. 

[:digit:] Any digit from '0' to '9'. 

[:letter:] Any of the characters considered alphabetic in any 

language. For example, it matches Thai letters, Greek 

letters, Hebrew letters, Latin letters, etc. 

[:letterdigit:] Any of the characters considered as alphanumeric in 

any language. 

[:num:], [:number:] Any digit from '0' to '9' and the following superscript 

and fractional numbers: '¹', '²', '³', '¼', '½', '¾' 

[:punct:], [:punctuation:] Any of the following characters: ! " # % & ' ( ) * , - . 

/ : ; ? @ [ \ ] _ { } ¡ « ­ · » ¿ 

[:sep:], [:separator:] Space (Hex 0x20) and non-breakable space (Hex 

0xA0) 

[:symbol:] Any of the following characters: $ + <=> ^ ` | ~ ¢ £ ¤ 

¥ ¦ § ¨ © ¬ ® ¯ ° ± ´ ¶ ¸ × ÷ 

[:space:] Space (Hex 0x20), tabs and carriage returns in the 

range Hex 0x09-0x0C, plus Hex 0x85 and Hex 

0xA0. 

[:xdigit:] Any hexadecimal digit from '0' to '9' and from 'a' to 'f' 

(or 'A' to 'F'). 
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Advanced Features 
ApSIC Xbench has some advanced features that you will appreciate when 

you have special needs. They are described in the following sections. 

PowerSearch function 

You can use the Ctrl+P (PowerSearch) key combination to search with 

more complex criteria. With the PowerSearch function you can search for 

entries:  

 That contain two or more strings, but not necessarily next to each 

other. 

 That do not contain a given string. 

 That contain a string or another string. 

 Any combination of the above conditions. 

Examples: 

This expression... ...does the following 

string1 string2 It finds all entries that contain "string1" 

and "string2" 

string1 or string2 It finds all entries that contain "string1" or 
"string2" 

string1 -string2 It finds all entries that contain "string1" but 

do not contain "string2" 

string1 -"string2 with embedded 

blanks" 

It finds all entries that contain "string1" but 

do not contain "string2 with embedded 

blanks" 

In more complex expressions involving several strings with Boolean 

and/or relationships, you can use parenthesis to indicate precedence. 

In PowerSearch mode, you need to use double quotes as delimiters if 

your expression contains embedded blanks or parenthesis. If your search 

string contains a double quote character embedded, you need to escape it 

using a sequence of two double quote characters. 

Note: If one of the words to search in PowerSearch mode is the word 

"or", you need to enclose the word "or" in double quotes to avoid that it is 

parsed as the or operator. 
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PowerSearch can be used in any of the searching modes: Simple, 

Regular Expressions, and MS Word Wildcards. 

Zooming In 
ApSIC Xbench features 4 types of zoom: 

 Zoom to Level. Shows the entries that belong to a given priority 

level. 

 Zoom to Glossary. Shows the entries that belong to a given glossary. 

If the glossary consists of only one file, it produces the same result as 

Zoom to File.  

 Zoom to File. Shows the entries that belong to a given file. 

 Zoom to Flag. Shows the entries that belong to those glossaries than 

have been assigned a given flag in their properties.  

As you already noticed, ApSIC Xbench shows a snapshot of the most 

relevant terms for each priority level on a single unified view. This allows 

you to analyze the sources of potential inconsistencies or even different 

meanings and make a more informed decision on which term to choose. 

However, it is possible that you want to see more (or all) instances of a 

specific level to make a more thorough analysis of a specific term. 

To do so, double-click the body of the window for the level that you want 

to zoom in to obtain a full list of entries for the searched term. The 

background will become green so that you can tell that you are in zoomed 

mode. 

To exit the zoomed mode, double-click the body of the window again. 

Reverse search 
ApSIC Xbench also defines a system-wide key for searching in the target 

column instead of in the source column. The default key combination for 

this feature is Ctrl+Alt+Backspace. 

This is equivalent to leaving the Source Term field blank and the Target 

Term field filled out. 

For example, this is convenient when you want to use a new term in your 

language and want to make sure that such a term is not already used in 

another term that could create potential clashes in the future with key 

terminology for your project. 
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Filtering the search scope 
The Search Options pane (View->Search Options) allows you to 

narrow the scope for the search. The filtering options available are: 

 Only New Segments: It shows only matches in segments that are not 

100% matches. 

 Only 100% Matches: It shows only matches in segments that are 

100% matches. 

 Only Ongoing Translation: It shows only matches in files that have 

been defined as ongoing translation in the project properties. 

 Exclude ICE Segments: It excludes In-Context Exact Matches (also 

known as 101% matches or Perfect Matches) from the search results. 

Seeing the context 
If you right-click on a search result and choose the See Context menu 

item, you will see all units that are found in the file physically before and 

after the current entry appear. 

Ignoring tags 
If search matches within the tags need to be excluded from the search 

results, you can choose the Ignore Tags check box in the Search 

Options pane.  

Editing the source 
document 

The Tools->Edit Source menu item, also attached to the Ctrl+E key 

combination, allows you to open the source file to which the entry 

currently selected belongs. This is very useful to quickly amend an issue 

detected in an ongoing translation. 

For many formats, for example when the source file is an SDLX itd file, a 

Trados Tag Editor ttx file, a Trados Word file, a memoQ file, a Trados 

Studio file or an IBM Translation Manager folder, ApSIC Xbench goes 

directly to the segment that contains the text. 
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For Transifex, it opens a window where you can type your correction and 

send it to Transifex, and for Matecat, it opens a browser with the online 

editor, right at the segment that needs to be edited. 

To use this feature with IBM Translation Manager, please ensure that 

IBM Translation Manager is up and running and that there is no 

document currently being edited. 

Line positioning is also available for Tab-delimited files and Trados 

exported memories, but your text editor parameters must be configured in 

Tools->Settings->Text Editor. For example, to configure TextPad 4 for 

line positioning, you must select there the Text Pad executable and 

specify the following in Command-Line Parameters: 

$filename($line,$column). Similarly, to configure Notepad++, you must 

select its executable and specify the following in Command-Line 

Parameters: $filename -n$line. Other text editors will require different 

values for this field. Please check your text editor's documentation for the 

suitable values. 

ApSIC Xbench also allows performing segment positioning for the TMX 

format, but the TMX editor must be configured in Tools->Settings-

>TMX Editor. For example, to configure OKAPI Olifant for segment 

positioning, you must select there the Olifant executable and specify the 

following in Command-Line Parameters: $Filename row=$Segment 
col=trg edit=yes. Other TMX editors might have different values for this 

field. Please check your TMX editor's documentation for the suitable 

values.  

This makes ApSIC Xbench a very useful and efficient tool to make 

global changes in terminology for these formats. If you afterwards want 

to regress the changes made, you can reload the ApSIC Xbench project 

with Project->Reload or View->Refresh. 

Search templates 
Search templates are predefined searches that you can choose or run. To 

use a search template, click on Search Templates... on the Search 

Options pane and then choose the search from the list. In Template 

Source, you can choose to show the Sample Search Templates or the 

Project Checklist entries. Click Search to run directly the search 

currently selected or click Choose to bring up the search template 

definition to the Source Term and Target Term fields. 
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Switching the layout of 
search fields 

You can switch between a vertical layout and a horizontal layout for the 

Source Term and Target Term fields in the Search tab. In the 

horizontal layout, the Target Term field appears next to the Source 

Term field and takes less screen space for the pane, hence there is more 

space available for search results. In the vertical layout, the Target Term 

field appears below the Source Term field and fields are therefore much 

wider.  

To switch between the vertical and the horizontal layout, simply pull up 

or pull down the bottom border of the Source/Target pane to shrink it or 

to expand it. 

 





 

 39 
 

Exporting Items 
ApSIC Xbench allows you to export the project items in the following 

formats: 

 TMX files 

 Tab-delimited text files 

 Excel files 

 Word files 

To export the contents of a project choose Tools->Export Items. The 

following dialog appears: 

 

In this dialog, you can export all items in a project, all items in the current 

query, only the items displayed in the current query (for example, if you 

are in overview mode, you only see a few items from each priority level), 

or all the items of a glossary that is a member of the project. 

If you wish, you can remove the repetitions (items that have exactly the 

same source and target values) from the exported data to reduce the size 

of the resulting file. You can also exclude the ICE (In-Context Exact 

matches) segments from the search. 

Additionally, you can limit the export to only untranslated items (for 

example to facilitate the feed to a machine translation system) or to only 

translated items. If you choose to export only the translated items, you 

can further specify if you wish to export only the pretranslated items (that 

is, items retrieved from a translation memory) or newly translated items. 

When exporting a tab-delimited text file or an Excel file, a header row 

can be added. The format of the exported Word file is the same format 

generated by Tools->Export Ongoing Translation to MS Word. 
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When exporting a TMX file, the source and target locales can be 

specified. You can specify any value in these fields. If you don't 

remember the locale code, you can press the ellipsis (...) button to open a 

helper window to enter the languages and countries.  

 

If you normally work with a limited set of files, you can click the arrow 

button of the combo box to open a shorter language list of recently used 

selections. 
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Working with Ongoing 
Translations 

ApSIC Xbench allows you to define any file as ongoing translation in the 

Project Properties window. 

By default, when they are added to an ApSIC Xbench project, the 

following file types are defined as ongoing translation: 

 XLIFF 

 Trados TagEditor 

 Trados Word 

 Trados Studio 

 memoQ 

 SDLX. Note: This option requires that SDLX is installed on the 

machine.  

 STAR Transit 2.6/XV/NXT 

 PO 

 IBM TM Folders 

 OpenTM2 Folders 

 Wordfast TXML/TXLF 

 Déjà Vu/Idiom 

 Logoport RTF 

 Qt Linguist 

 Transifex Project 

 Matecat Job 

When a file or directory is defined as ongoing translation, the following 

two features are enabled: 

 Translations identified as new (not 100% matches) are flagged with a 
small red dot ( ). Translations that are 100% matches in the ongoing 

translation are flagged with a hollow red dot ( ). These symbols allow 

you to tell if the term was introduced by you or was already in the 

existing memory. This helps you to make terminology-related 

decisions, for example if you wish to recap on the translation for a 

term and you want to make sure that the term was not already used in 

the official translation memory used to pretranslate your project. 

 Untranslated segments appear after the translated segments. This is 

especially useful to decide which terminology to use for a new term 

by seeing how it will appear in all the future instances in your own 

translation. This way you can make sure that the term chosen will be 

a good match for all instances in your current translation. 
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Note: Glossaries defined as ongoing translation (normally only one per 

project, but can be more) appear in bold face in the Project Properties 

window. 

In addition, files defined as ongoing translation can be parsed by ApSIC 

Xbench powerful QA functions or exported using Tools->Export 

Ongoing Translation to MS Word so that you can use Microsoft Word 

Grammar Checker or Microsoft Word Spell-Checker (for languages such 

as Thai, Japanese or Chinese that are not supported by Xbench spell-

checking dictionaries). 
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Key Terms 
ApSIC Xbench allows you to define one or more files as Key Terms. To 

do so, when in the list of glossaries in Project Properties, choose the 

Key Terms check box. A green star will appear next to the glossary entry 

as shown in the illustration below to indicate that the glossary belongs to 

the Key Terms category. 

 

When a file is defined as Key Term, its entries appear with a star on top 

of the results. The color of the star indicates if the key term is an exact 

match (green star ), an exact match except for the case (yellow star ), 

or if the text searched is contained in the key term entry (empty star ). 
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The example below shows entries "clipboard" and "Clipboard Viewer", 

which are flagged as Key Terms: 

 

In the example above, the green solid star for the "clipboard" entry means 

that the entry is a full match. The empty star in the "Clipboard viewer" 

entry means that the searched term is part of a key term. 

The QA feature also makes use of Key Terms defined for the project by 

checking if they have been used in the ongoing translation. 
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ApSIC Xbench features Quality Assurance (QA) functions to perform 

advanced checks on the files defined as ongoing translation. The QA 

functions try to find segments with the following potential problems: 

 Untranslated segments 

 Segments that have the same source text but a different target text 

 Segments that have the same target text but a different source text 

 Segments where the target text matches the source text 

 Segments with tag mismatches 

 Segments with number mismatches 

 Segments with URL mismatches 

 Segments with alphanumeric mismatches 

 Segments with unpaired symbols (i.e. unpaired parentheses, square 

brackets, or braces) 

 Segments with unpaired quotes 

 Segments with double blanks 

 Segments where words fully in UPPERCASE do not match between 

source and target 

 Segments where words in CamelCase do not match between source 

and target  

 Segments that deviate from the key terms of the project 

 Segments that meet the search criteria of items in the Project or 

Personal Checklists. See Managing Checklists for more information 

about this feature. 

 If you have installed dictionaries with Tools->Spell-Checking 

Dictionaries, segments with spell-checking issues.  

  

The Quality Assurance functions are carried out with the QA tab in the 

main window. The QA tab can perform the following functions: 

Working with Quality Assurance 
Features 
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Perform all checks selected in Check Group and List of Checks by 

clicking Check Ongoing Translation. By default all available checks are 

selected, except Target same as Source. 

 Perform only the searches defined by the Project Checklists by 

clicking on Run Project Checklists. 

 Perform only the searches defined by the current Personal Checklists 

by clicking on Run Personal Checklists. To change the current 

Personal Checklists, choose Tools->Manage Checklists. 

 Export the displayed QA results by right-clicking and choose Export 

QA Results to the following formats: HTML, tab-delimited text, 

Excel, or XML. 

Note: Please remember that the ApSIC Xbench license does not permit 

removal of the credits on the right-hand side at the beginning of the 

exported QA report. We have tried to make this credit information non-

intrusive and its aim is to avoid tell-a-friend or other more intrusive ways 

of promoting use of the product among peers.  

Results are shown in the body window of the QA tab. For some file 

formats, you can open directly from ApSIC Xbench the file at the segment 

shown to correct it by selecting Tools->Edit Source or by pressing 

Ctrl+E. 

You can limit the scope of the strings considered by the QA process by 

checking the Only New Segments, Only 100% Matches, or Exclude 

ICE Segments check boxes.  

You can also make the consistency check mode case-sensitive by 

checking the Case-sensitive Inconsistencies check box. 

You can ignore the tag content within the segments for the QA pass by 

choosing Ignore Tags. This will allow you to find inconsistencies that 

have the same source or target text except for inline tags. 

This window allows you to mark an issue by right-clicking on it and 

choosing Mark/Unmark Issue. You can then optionally show or hide 

marked issues with the Show Marked or Hide Marked radio buttons 

under Filter Issues in order to limit the number of issues displayed. For 

example, to quickly ignore and hide false alarms from the list of results, 

one good set-up is to choose Hide Marked and then mark issues as you 

process the list.  

Note: The Export QA Results command only exports displayed issues (it 

does not export hidden issues). 
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Managing Checklists 
Checklists are a very useful Quality Assurance (QA) function in ApSIC 

Xbench. Built on ApSIC Xbench search engine, checklists are a 

compilation of searches that can be run in batch to identify segments with 

problems. Typically, you store in checklists common pitfalls, such as use 

of banned terms or expressions. It is a very good practice to compile 

client feedback in checklists to make sure that no feedback is forgotten in 

subsequent deliveries of translations. 

In the QA tab of the main window, you will be able to run these 

checklists against all files defined as ongoing translation in the ApSIC 

Xbench project. 

Since checklists are built on top of ApSIC Xbench search engine, 

anything that can be searched for in ApSIC Xbench can be added to a 

checklist. Actually, one useful means of adding a search into the checklist 

is by searching it first in the Project tab, and then clicking Add Last 

Search to Checklist in the Search Options pane of the main window. 

There are two types of checklists: Project Checklist and Personal 

Checklist. 

The Project Checklist is saved with the ApSIC Xbench project file (.xbp 

extension) and normally it contains checks that are specific of the project, 

such as checking if some untranslatable keywords have been accidentally 

translated.  

Personal Checklists are not saved to the ApSIC Xbench project file. 

Instead they are saved to an ApSIC Xbench checklist file (.xbckl 

extension). ApSIC Xbench remembers the last set of personal checklists 

used across projects. You can have any number of personal checklists 

loaded at any given time. Personal checklists normally contain non-

project types of checks, such as a common misspelling that survives the 

spell checker or a generic language rule that is interesting to check across 

projects. They are called "personal" because the terms compiled in these 

lists normally are filled with the errors that a given translator is more 

prone to do. 

Checklists are managed in the Checklist Manager tab. You can open the 

Checklist Manager tab with the following methods: 

 Choose View->Checklist Manager. 

 Click the Checklist Manager icon on the tool bar. 

The Checklist Manager allows you to work with your Project and 

Personal Checklists. 
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In the Checklist Manager, you can create new Personal Checklists by 

choosing Checklist->New when the cursor is placed on Personal 

Checklists group in the navigation tree. You can also add an existing 

checklist with Checklist->Add. All of the personal checklists listed 

under Personal Checklists will be run when you click Run Personal 

Checklists or Check Ongoing Translation on the QA tab. 

The <Project> checklist is stored in the ApSIC Xbench project file (.xbp 

extension), and cannot be removed from the Project Checklists group in 

the navigation tree. You can add more checklists to the Project 

Checklists group, which will be run when you click Run Project 

Checklists or Check Ongoing Translation on the QA tab. The items in 

these additional project checklists are not saved to the ApSIC Xbench 

project file itself but they become linked to the project, so next time you 

open the ApSIC Xbench project file, any checklists linked to it will also 

appear here. 

The entries in the checklist selected on the navigation tree are shown on 

the body of the window. You can sort by any of the columns. If you wish 

to disable an individual entry, you can right-click it and choose Disable. 

Please note that the disabled state is saved to disk, so next time that you 

open the same checklist the entry will remain disabled. 

You can test the selected checklist item against the loaded project by 

right-clicking a check list item and choosing Test. This action will run a 

search with the checklist item settings in the Search tab, so that you can 

see if the search results returned match the expected behavior. 

When you click on a column heading, the list is sorted by that column 

alphabetically. If you click on the column heading a second time, the list 

is sorted from bottom to top. If you type a sequence of characters, the 

current column will be searched for the typed sequence of characters. 

Individual checklist entries can be added or edited. Fields available are 

the same that can be specified in the Search Options pane of the Search 

tab. 



 

 Chapter 12 Managing Checklists 49 
 
 

 

In addition, you can also specify a category for the checklist entry in the 

Category combo box. You can specify here any category name. If you 

wish to use a previously defined category name, you can expand the 

combo box by clicking the arrow button and choose it from the list. If you 

have created category names, you will be able to run selectively subsets 

of categories when you run a project or personal checklist from the QA 

tab using the Run Project Checklists or Run Personal Checklists 

buttons. 

You can also define inheritance relationships between checklists. When a 

checklist inherits from another one, all entries are inherited. You can 

inherit from several checklists. 

To inherit a checklist, do the following. 

1. Click the Inheritance button and then right-click on the list of 

inherited items that appears and choose Add. 

2. Type a name for the inherited checklist and choose the file name that 

contains it. The name specified here does not need to match the checklist 

display name. 

 

3. Add any required checklists following steps 1 and 2. The dialog will 

show the inherited items with the  icon. You can override these 

inherited items but not edit or delete them. 
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Once you set an inheritance relationship, any changes or additions you 

make in the parent checklist will be inherited. 

The Project Checklist is saved automatically when you save the project. 

If you add entries to the Project Checklist and then shut down ApSIC 

Xbench, you will be prompted to save the project. 

Changes made to all checklists are saved automatically, except for the 

<Project> checklist that will be saved with the .xbp Xbench project file.  

If you wish to make changes to a checklist but not save them to it, you 

can create a duplicate of a checklist right-clicking on it and choosing 

Save as. 

 



 

 51 
 

Running QA from 
Windows Explorer 

ApSIC Xbench includes a shell extension that allows you to start a QA 

session right from Windows Explorer. This can be very handy when you 

want to run a simple QA pass of one or more files or of a directory. 

To run QA from Windows Explorer: 

1 In Windows Explorer, select the file or directory that you wish to 

QA. 

2 Right-click and choose Run QA with Xbench. 

These actions will launch ApSIC Xbench with a newly created project 

that considers on-going translation all files selected with Windows 

Explorer. 

The project is now ready to run a QA pass. If you wish to further 

customize the ApSIC Xbench project just created, for example to add a 

Key Terms file, you can do so in Project->Properties. 

The project created with Windows Explorer is in your Windows TEMP 

directory. If you wish to save the ApSIC Xbench project for further reuse, 

you can choose Project->Save As and give it a new name in a new 

location on your computer. 
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Working with ApSIC 
Xbench Instant Spell-
Checker 

ApSIC Xbench features an innovative method for instantly spell-

checking all ongoing files in your project. Instead of opening and closing 

many files and slowly traversing them with a spell-checker, ignoring false 

alarms, ApSIC Xbench processes all files as a block and then presents 

you the consolidated results so that you can flag real misspellings very 

quickly. 

ApSIC Xbench provides 48 spell-checking dictionaries based on the 

Hunspell engine as front-end and Microsoft Word dictionaries as backend 

if Microsoft Word for that language is installed on the machine. Only 

words that do not exist in both dictionaries are flagged as errors. The pass 

with Microsoft Word dictionary can be disabled if Settings->Use 

Microsoft Word dictionary is deselected in the ApSIC Xbench Spell 

Checker window. 

Spell-checking dictionaries themselves are not included in ApSIC 

Xbench installer. Instead, you should download and install them with 

Tools->Spell-Checking Dictionaries. 

 

When you add a spell-checking dictionary, the added language appears in 

the Spell-checking group. 
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To include spell-checking in the checks to be done, choose Spell-

checking and then select the language in List of Checks. Then click 

Check Ongoing Translation. 

 

The window that appears shows you all spell-checking issues, grouped by 

misspelled term. Browse through the list, and double-click on those 

issues to move the misspelled word to the Real Misspelling list. 

Once you have gone through the whole list, click OK to add the segments 

with misspelling issues to the main QA report. 

In the Spell-Checking window there are a few settings that can allow you 

reduce the number of false alarms listed. To show them, click 

Exclusions. 

 

The options available in this pane are: 

 Words with numbers. When checked, it does not consider words 

like Pkd05 or G5HJKH7 to be misspelled. 

 Words in mixed case with a match in source text. When checked, 

it does not consider words like PlantWorks to be misspelled if the 

term also appears on the source text. 

 Segments where target text matches source text. When checked, it 

does not perform any kind of spell-checking on segments where 

target text matches exactly with the source text. If you are already 

using the QA check Basic->Target same as Source, this exclusion 

will allow you to skip words in segments that were deliberately left in 

the original language.  



 

 Chapter 14 Working with ApSIC Xbench Instant Spell-Checker 55 
 
 

 Words in UPPERCASE. When checked, this setting will not spell 

check words that are in uppercase.  

 Words in UPPERCASE with a match in source text. When 

checked, this setting will not spell check words that are in 

UPPERCASE if the exact same words are also in uppercase in the 

source text. This setting can be useful if your translation has many 

acronyms that do not change across languages.  

 Abbreviations. When checked, this setting will skip abbreviations. 

Using Addendums 
If your translations contain client-specific terms, such as products, 

brands, common keywords, and so on, it is likely that the dictionaries 

provided do not include them. The ApSIC Xbench spell-checker allows 

you to create one or more addendums for each given dictionary, so that 

you can enable them depending on your project's needs. 

To create a new addendum to a dictionary, please do the following: 

1 Choose Addendums->Manage Addendums. 

 

2 Click Add. 

3 Enter a name for the addendum and click OK. 

Once created, if you want to add one or more terms to the addendum, 

select them in the list of issues, right-click and choose Add to 

addendum: <addendum_name>. 

 

You can add as many addendums as you wish to any dictionary. The 

addendums are stored in the path specified by Settings->Set Addendum 

Folder. 
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Additional Spell-Checker 
Features 

The ApSIC Xbench spell-checker has some additional interesting 

features: 

 You can change the font size by right-clicking on the Unknown 

Words list, choosing Settings and then Enlarge Font or Reduce 

Font. 

 You can copy the unknown words to the clipboard by right-clicking 

on the Unknown Words list, choosing Export and then Copy to 

Clipboard. 

 You can open Microsoft Word or Microsoft Excel with the unknown 

words by right-clicking on the Unknown Words list, choosing 

Export and then Open in MS Word or Open in MS Excel. Opening 

in Microsoft Word can be useful if, for example, you want to spell 

check the remaining unknown words with Microsoft Word. 

 By default, you flag real misspellings by double-clicking on them and 

moving them to the Real Misspellings list box. This is done under 

the assumption that most unknown words will be false alarms, which 

is often the case in a final check or regression. However, if your case 

is the other way around, you may want to change the working mode 

so that instead of flagging real misspellings, you flag false alarms 

instead. To change the working mode, choose Settings->Change 

Working Mode.  

Grammar and Spell-Check 
in Microsoft Word 

You can use Tools->Export Ongoing Translation to MS Word to 

create a Microsoft Word file with source and taget text side-by side. By 

default, the source text is flagged as "no proof", so you can use F7 to 

proof the target column using Microsoft Word spell-checker or grammar 

checker, if it is installed for your language. For example, you can use this 

Word document to proof languages that are not listed among Xbench 

spell-checking dictionaries, such as Thai, Finnish, Japanese, or Chinese. 

When you find an issue that you wish to fix, you can select it in Word, 

press Ctrl+Alt+Backspace to find the segment in Xbench and then press 

Ctrl+E to open the segment with the typo in the native editor, such as 

Trados Studio or memoQ. 
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Working with the ApSIC 
Xbench Plugin for SDL 
Trados Studio 2014 

The ApSIC Xbench Plugin for SDL Trados Studio 2014 allows you to: 

 From SDL Trados Studio 2014, create an Xbench project 

automatically gathering information from your current SDL Trados 

Studio 2014 project, and then automatically launch ApSIC Xbench so 

that you can run QA on the files of the project. 

 From ApSIC Xbench, use the Edit Source command from the 

Search tab or the QA tab to open an sdlxliff file in SDL Trados 

Studio right at the segment that is currently selected in Xbench and in 

the SDL Trados Studio project context (connected translation 

memory and termbase). 
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Installing and Uninstalling 
the Plugin 

Before you install the ApSIC Xbench Plugin for SDL Trados Studio 

2014, you need to make sure that you have the following software 

installed on your machine: 

 SDL Trados Studio 2014 SP1. The Help->About SDL Trados Studio 

box should show version 11.1.3931 or later. 

 ApSIC Xbench 3.0 build 1186 or later. 

If you do not have these versions, please download and install them 

before installing the plugin. 

You can download ApSIC Xbench 3.0 and the ApSIC Xbench Plugin for 

SDL Trados Studio 2014 from the Download page at 

http://www.xbench.net. The plugin installable file can be used both with 

the 32-bit and the 64-bit editions of ApSIC Xbench 3.0. 

Installing the Plugin 
To successfully install the plugin, you need administrative rights. The 

plugin will be installed for all SDL Trados Studio users on the machine. 

After installing the plugin, you need to run at least once SDL Trados 

Studio 2014 as administrator to unpack the plugin. This is especially 

important if you install the plugin on a Terminal Server, where there can 

be users without administrative rights. 

To install the plugin, click the Setup.Xbench.Plugin.Studio.3.0.n.exe that is 

found in the file you downloaded from http://www.xbench.net, and 

follow the installation wizard instructions. 

Uninstalling the Plugin 
To uninstall the ApSIC Xbench Plugin for SDL Trados Studio 2014, 

simply go to the Windows Control Panel and uninstall it. 

Please note that you need administrative rights to uninstall the plugin. 
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Using the Plugin 
When you launch SDL Trados Studio with the ApSIC Xbench Plugin 

installed, the first thing you will probably notice is that the ribbon for the 

Projects view has a new guest. 

 

The ApSIC Xbench Plugin installs an icon in these three ribbons: 

 The Home ribbon of the Projects view 

 The Home ribbon of the Files view 

 The Review ribbon of Editor view 

Any of these icons performs the same action: Run QA in Current 

Project. 

The Run QA in Current Project action does the following: 

1 Creates an ApSIC Xbench project (.xbp extension) with the following 

items: 

 All sdlxliff files for the current project loaded as ongoing 

translation and with medium priority (red color). If your project 

has more than one target language, the Choose Language dialog 

will appear. 

 

 The first file-based translation memory with .sdltm extension 

found for the language in the SDL Trados Studio project settings. 

The ApSIC Xbench plugin first scans the language-specific 

settings and if no translation memory is found, it proceeds with 

the All Language Pairs settings. This translation memory is 

loaded with low priority (blue color) in the Xbench project. You 

can disable the load of the translation memory using ApSIC 

Xbench by choosing Tools->Settings->Studio Plugin and then 

deselecting the Add first local translation memory checkbox. 

Note: If you choose All Languages in the Choose Language 

dialog, this file will not be loaded in the Xbench project. 
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 The first file-based termbase with .sdltb or .mdb extension found 

for the language in the SDL Trados Studio project settings. This 

MultiTerm glossary is loaded with high priority (green color) in 

the Xbench project. You can disable the load of the termbase by 

using ApSIC Xbench by choosing Tools->Settings->Studio 

Plugin and then deselecting the Add first local termbase 

checkbox. Note: If you choose All Languages in the Choose 

Language dialog, this file will not be loaded in the Xbench 

project. 

2 Launches ApSIC Xbench to load the project and opens the QA tab in 

ApSIC Xbench. 

Once in Xbench, you can select your desired QA settings and choose 

Check Ongoing Translation to run the QA. Please remember that only 

ongoing translation files (in our case the sdlxliff files) are considered for 

QA. Any other files are considered reference for ad hoc searches. 

During QA, you may want to search your sdlxliff files and the glossary or 

translation memory. You can do so in the Search tab of ApSIC Xbench. 

The illustration below shows how the information is organized in the 

generated Xbench project. 

 

When you find an item in the Search or QA tabs that you want to 

change, simply choose the item, right-click and then choose Edit Source. 

You can also press Ctrl+E as a shortcut to run the Edit Source 

command. When you do so, SDL Trados Studio will go to the foreground 

and the Editor view will open the file right at the segment that you chose 

in ApSIC Xbench. 
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Once you have made your change in SDL Trados Studio, you can go 

back to Xbench using the Alt+Tab hot key.  

After you have done your QA changes in SDL Trados Studio, you can 

quickly run a regression QA pass by pressing again the icon in the ribbon. 

When you click the ribbon icon, the Xbench plugin will save any unsaved 

files and will create a new Xbench project with the updated files. 

If you want to run a QA for only some of the files in the SDL Trados 

Studio project, simply go to the SDL Trados Studio Files view, select the 

desired files, right-click to bring up the popup menu and then choose Run 

QA in Selected Files with Xbench. 
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How to Run QA on 
memoQ Files 

 

Instructions for memoQ 6 
to memoQ 2014 until  
build 51 

ApSIC Xbench can load memoQ .mqxliff and .mqxlz files. To add a 

memoQ document to an Xbench project, you need to do the following:  

1 In memoQ, select the document, choose Export bilingual, choose 

memoQ XLIFF as the output format and click Export.  

2 In ApSIC Xbench, choose Project->Properties, choose Add and 

then choose memoQ File.  

However, the Editor Source command that allows you to go to the same 

segment in memoQ has one important limitation: it only works if the 

current mqxliff document is open in memoQ. 

Therefore, in order to get the most of the integration with memoQ, you 

need to put the content you want to QA in a single .mqxlz file. You can do 
by creating a view in memoQ and exporting it. Therefore the recommended 

procedure to QA memoQ files is as follows: 

1 In memoQ, select in the Translations view all documents that you 

want to QA from the current project, right-click and choose Create 

View. Type something like ToXbench in Name of the view, choose 

Simply glue documents together and click OK. 

2 In memoQ, in the Views tab, select ToXbench, right-click and choose 

Export bilingual. Choose memoQ XLIFF and click Export. 

3 Open the ToXbench view in the editor so that it is shown in the 

translation grid. 

4 In ApSIC Xbench, choose Project->Properties, choose Add and 

then choose memoQ File. Add the ToXbench.mqxlz file you created 

in step 2. 

C H A P T E R  1 8  



 

66 Using ApSIC Xbench  
 

With this setup, that is, with the ToXbench view open in memoQ and the 

corresponding mqxlz file loaded in ApSIC Xbench, if you choose Edit 

Source in ApSIC Xbench, it will position in memoQ to exact same 

segment that you have currently selected in Xbench.  

This means that if you find an issue while running a QA on the memoQ 

file in Xbench, you can fix it directly in memoQ by simply choosing Edit 

Source (Ctrl+E). 

Instructions for memoQ 
2014 build 51 or later 

A new feature was added to memoQ 2014 build 51 that simplifies the 

interoperability with ApSIC Xbench. Starting with this memoQ build, the 

instructions to QA a memoQ project are as follows: 

1 In memoQ, select the documents, choose Export bilingual, choose 

memoQ XLIFF as the output format and click Export to a folder, for 

example ToXbenchQA. 

2 In Windows Explorer, select the ToXbenchQA directory, right-click 

and choose Run QA in Xbench (this is a bit faster than using 

Project->Properties in ApSIC Xbench). 

3 Run the QA (or search) in ApSIC Xbench normally. When you see a 

memoQ segment in the QA or search results that you wish to edit, 

just select it, right-click and then choose Edit Source (Ctrl+E). 
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You will find here several topics that will provide you additional 

information on ApSIC Xbench features. 

 

Additional Information 
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Working with ApSIC 
Xbench Settings 

On the Tools menu, click Settings to open the Settings dialog as shown 

in the illustration below. 

 

In this dialog, you can set ApSIC Xbench to always start in maximized 

mode (recommended) and also change the default hotkeys that are 

available system-wide. Note: Changing the default hotkeys should be 

necessary only as a workaround to avoid clashing with any other 

application using the same keys. 

The fields in this dialog are: 

Maximize on Startup. If you check this box, ApSIC Xbench will appear 

maximized when it is launched. It is recommended to check this box, as 

the maximized mode is the one that provides the maximum amount of 

information at the same time. 

The following settings belong to the Hotkeys group.  

Disable. This check box lets you disable the system-wide key 

combinations featured by ApSIC Xbench. It is recommended to leave 

this box unchecked as one of the most valuable features of ApSIC 

Xbench is the capability to search directly from any application. 

Source Hotkey. This is the hotkey defined to trigger a search of the 

clipboard contents in the source text. By default it is Ctrl+Alt+Insert. 
Target Hotkey. This is the hotkey defined to trigger a reverse search 

of the clipboard contents in the target text. By default it is 

Ctrl+Alt+Backspace. 
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It is recommended not to change these hotkey settings unless they clash 

with the values in another application. 

Internet Search / Open in default browser. When checked, it opens 

your Internet searches in your default browser, instead of opening it in 

ApSIC Xbench embedded browser. 

Transfer Method. ApSIC Xbench uses the clipboard as a transfer 

mechanism between the different Windows applications and ApSIC 

Xbench. Normally the most convenient and consistent transfer method is 

to leave the default options Manual Copy and Manual Paste, but in 

some scenarios (for example with applications that do not feature 

standard copy and paste keystrokes), you may have to change these 

settings to get the most out of ApSIC Xbench. 

The options available as a transfer method for Input are: 

Copy Message. When you press Ctrl+Alt+Insert, ApSIC Xbench 

sends a COPY message to the application to copy the selected text 

into the clipboard and then performs a search using the contents of 

the clipboard. A limited number of applications support this 

technique, but it has the advantage of avoiding the need for copying 

manually the text into the clipboard (normally with Ctrl+Insert). 
Manual Copy. In this mode, ApSIC Xbench expects that the user has 

already copied the text to search in the clipboard. It sounds more 

tedious, but it has the advantage that many applications support the 

Ctrl+Insert key combination for copying text, which means that you 

feel a more consistent behavior across applications. On the downside, 

if the editing application has a slow response time, you may go too 

fast with the combination Ctrl+Insert, Crl+Alt+Insert for the 

application. 

Keyboard Emulation (Ctrl+Insert). In this mode, ApSIC Xbench 

sends the Ctrl+Insert keystroke to the editing application and then 

performs the search. This way the user needs not to type Ctrl+Insert 
manually prior to the search. Some applications may not support this 

input method. 

Keyboard Emulation (Ctrl+C). In this mode, ApSIC Xbench sends 

the Ctrl+C keystroke to the editing application and then performs the 

search. This way the user needs not to type Ctrl+C manually prior to 

the search. Some applications may not support this input method. 

The options available as a transfer method for Output are: 

Paste Message. When your press Enter to select a translation, ApSIC 

Xbench sends a PASTE message to the application to paste the 

translation. A limited number of applications support this technique, 

but it has the advantage of avoiding the need for pasting manually the 

text into the clipboard (normally with Shift+Insert). 
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Manual Paste. In this mode, ApSIC Xbench copies the target text of 

the selected entry into the clipboard if you press Enter to select a 

translation. The user is expected to press Shift+Insert (or the 

corresponding key combination for pasting text in the application) to 

complete the copy and paste operation. This is the default and 

recommended mode for consistency reasons across applications. 

Keyboard Emulation. In this mode, ApSIC Xbench sends the target 

text by simulating that it is entering the text to the editing application 

when you select an entry and press Enter to copy the selection into 

the clipboard. 

Keyboard Emulation (Ctrl+V). In this mode, ApSIC Xbench sends 

the target text by simulating the Ctrl+V keystroke to the editing 

application when you select an entry and press Enter to copy the 

selection into the clipboard. 

Click the Colors tab of this dialog to change the default colors of the 

main window. The following window appears: 

 

Settings in this tab are the following: 

 Background color when zoomed. In ApSIC Xbench there are two 

modes: overview, with some entries from the priorities shown, and 

the zoomed mode, where all the entries of a given priority are shown. 

This is the background color that is used in zoomed mode, as an 

indicator that you are not in overview mode (the default mode is 

overview). 

 Key Terms priority. This is the color that will be used for entries 

that belong to the Key Terms priority. A glossary is defined as a Key 

Terms glossary in Project->Settings. 

 High Priority. This is the color that will be used for entries 

belonging to the high priority.  

 Medium Priority. This is the color that will be used for entries 

belonging to the medium priority. 

 Low Priority. This is the color that will be used for entries belonging 

to the low priority. 
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 Background color when nothing found. This is the background 

color that appears in the search box when no entry is found. 

Click the Internet tab to work with Internet definitions: 

 

The Internet tab lets you define the pattern URLs that you use to perform 

targeted searches in the Internet, for example in a dictionary. You can 

have as many entries as you wish, but only the first 10 will have a hotkey 

assigned, either Alt+n within ApSIC Xbench or with Ctrl+Alt+n (with 

the numeric keypad in this latter case in Num Lock mode) from any 

Windows application. n can be a number from 0 to 9, where the 0 

corresponds to the 10th entry in the list. 

To add a new entry, press the arrow down key in the last entry. To 

remove an entry, remove all text from the row.  

You can use the Up and Down buttons to move an entry up or down in 

the list. 

The up to 10 entries with a key assigned appear in the Internet menu. 

You can choose Internet->Capture URL to capture URLs into this list. 
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The Miscellaneous tab lets you specify various settings that may improve 

your experience as you get familiar with ApSIC Xbench. 

 

Settings in this tab are the following: 

 Check weekly for new versions. If this check box is enabled, ApSIC 

Xbench will check once a week if there are updates available. 

 Enable alternative project. If this check box is checked, ApSIC 

Xbench keeps in memory the project opened prior to the current one. 

To switch back and forth among both projects, choose Project-

>Switch to Alternative Project. To discard the alternative project 

and recall the memory used by it, choose Projects->Forget 

Alternative Project. 

 Load last project when ApSIC Xbench starts. If this check box is 

checked, the next time ApSIC Xbench is started, it will load the 

project that was opened at the time of the last shut down. 

 Show warning when copying fuzzy match. If this check box is 

checked, ApSIC Xbench will issue a warning message if you press 

Enter to copy the entry currently selected in the search results and 

such entry does not match exactly the searched term. 

 Show warning when shutting down. If this check box is checked, 

ApSIC Xbench will issue a warning message when you shut it down. 

 Show QA options changed from default. If this check box is 

checked, QA results will include at the top a list of all QA settings 

that do not have the default value defined by ApSIC. 

 Match whole words in QA check for key terms. If this check box is 

checked, the target term of an entry of a glossary defined as key terms 

should match as a whole word (please note that the source term is 

always matched as a whole word). 

 Show metadata in exported QA reults. When enabled, ApSIC 

Xbench will show the segment metadata in the Comments column of 

the exported QA report.  

 Default project directory. This field allows you to specify the 

default folder for your ApSIC Xbench projects. 
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 Manage Cloud Settings. This button allows you to set which 

Xbench settings, such as URLs or colors, should be replicated to the 

cloud so that they are also available in other computers from which 

you sign in to your Xbench account. 

The Text Editor tab lets you configure command-line arguments for a 

text editor when using the Edit Source feature for search or QA results 

for a glossary in .txt format. This includes Tab-delimited Files, Trados 

Exported Memories, Wordfast Memories, and Wordfast Glossaries. 

When properly configured, this allows you to open the file directly at the 

line from which the segment selected with Edit Source comes from.  

 

If you choose to define a Text Editor, you need to assign values to the 

following fields: 

 Path to Executable. This is the path to the .exe file for the text 

Editor. You can use the button with the ellipsis (...) to navigate to the 

.exe file. 

 Command-line Parameters. This field allows you to construct the 

command-line that should be passed to the editor. You can use 

several variables that will be replaced with values by ApSIC Xbench: 

 $Filename: The file name, including its path of the file. 

 $Line: The line number of the segment in the text file. This line 

refers to where the target text is located. 

 $Column: The column in the line where the target text is located. 

 $Segment: The segment number in the text file. 

For example, to configure TextPad 4 for line positioning, you must 

select there the Text Pad executable and specify the following in 

Command-Line Parameters: $filename($line,$column). Similarly, to 

configure Notepad++, you must select its executable and specify the 

following in Command-Line Parameters: $filename -n$line. Other 

text editors will require different values for this field. Please check 

your text editor's documentation for the suitable values. 
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The TMX Editor tab lets you configure command-line arguments for a 

TMX editor when using the Edit Source feature for search or QA results 

for a glossary in .tmx format. When properly configured, this allows you 

to open the file directly at the line from which the segment selected with 

Edit Source comes from.  

 

If you choose to define a TMX Editor, you need to assign values to the 

following fields: 

 Path to Executable. This is the path to the .exe file for the text 

Editor. You can use the button with the ellipsis (...) to navigate to the 

.exe file. 

 Command-line Parameters. These fields allows you to construct the 

command-line that should be passed to the editor. You can use 

several variables that will be replaced with values by ApSIC Xbench: 

 $Filename: The file name, including its path of the file. 

 $Line: The line number of the segment in the text file. This line 

refers to where the target text is located. 

 $Column: The column in the line where the target text is located. 

 $Segment: The segment number in the text file. 

For example, to configure OKAPI Olifant for segment positioning, 

you must select there the Olifant executable and specify the following 

in Command-Line Parameters: $Filename row=$Segment col=trg 
edit=yes. Other TMX editors might have different values for this 

field. Please check your TMX editor's documentation for the suitable 

values.  
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The Studio Plugin tab lets you configure settings that modify the 

behavior of the ApSIC Xbench Plugin for SDL Trados Studio. 

 

The settings available on this tab are: 

 Add first local termbase. When checked, the plugin will add the 

first local termbase defined for the SDL Trados Studio project to the 

Xbench QA project created from the plugin. The termbase will be 

assigned high priority in the Xbench project. 

 Add first local translation memory. When checked, the plugin will 

add the first local termbase defined for the SDL Trados Studio project 

to the Xbench QA project created from the plugin. The translation 

memory will be assigned low priority in the Xbench project. 

 Use this Xbench project template. When checked, it will instruct 

the plugin to add Studio files to the Xbench .xbp project indicated in 

the field below. Use the ellipsis button (...) to open a Windows 

Explorer to select the .xbp file. 

The Transifex tab lets you configure the Transifex user that will be used 

to retrieve project information from Transifex and your default target 

language. 
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The items available on this tab are: 

 User name. The Transifex user name. 

 Password. The password of the Transifex user. 

 Test Login. Click this button to check if the Transifex credentials are 

correctly typed. 

 Default target language. Type here your default target language in 

Transifex projects. If you press the ellipsis (...) button, a list of valid 

target languages will be shown. 
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ApSIC Xbench Quick Tips 
This chapter focuses on the most important features of ApSIC Xbench 

and aims to be a quick view of what ApSIC Xbench can do. 

We strongly recommend reading this chapter to get the most out of 

ApSIC Xbench with the minimum learning effort. 

 ApSIC Xbench is not an indexer. It reads the contents of the files 

each time you load a project and tries to respond to terminology 

queries very fast. Therefore, loading all of the Microsoft glossaries 

for a major language can take several minutes and will require a 

significant amount of memory. If you plan to load huge amounts of 

reference in the range of tens of millions of words, it is strongly 

recommended to have at least 1 GB of memory. If you don't have a 

very powerful machine, we do not recommend loading all Microsoft 

glossaries but a more focused selection with the subject areas that 

pertain to your current translation project. 

 Once loaded, ApSIC Xbench stays active in the background until it is 

explicitly shut down. When ApSIC Xbench is active, a pink gem 

appears in the system tray. To unload ApSIC Xbench from memory, 

you must shut it down. For example, you can shut it down by right-

clicking on the icon in the system tray and then choosing Shut Down 

Xbench. 

 While ApSIC Xbench is active, it can be called from any Windows 
application with the Ctrl+Alt+Insert key sequence. If there is text 

marked in the application, ApSIC Xbench searches automatically the 

text marked. The actual keystrokes are configurable. 

 In addition to the Microsoft software glossaries, ApSIC Xbench 

supports many input formats from a number of CAT applications, 

including Trados, memoQ, Wordfast, Memsource, Matecat, SDLX, 

Transit, and other industry-standard formats such as TMX, TBX, or 

XLIFF. You can combine the different formats into one Xbench 
Project by assigning priorities to each source to define the terminology 
decision process of your specific translation project. You can save 

each ApSIC Xbench project for later reuse. 

 You can copy the target text of the currently selected item into the 

clipboard by pressing Enter in the main window. The Enter key closes 

the window copying the text so that it is ready for pasting in the 

application where you edit your translation using Shift+Insert. This is 

very useful when translating the documentation of a software 

application whose software strings are loaded into an ApSIC Xbench 

project. 

 QA checks can be run using the QA tab. QA checks are run only 
against files defined as ongoing translation. A very powerful QA 

feature are checklists, which allow you to run in batch a number of 

predefined checks using the powerful ApSIC Xbench search 

capabilities. 
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After getting some familiarity with the basic capability of the product, we 

do encourage you to read the documentation with more detail to learn 

about many useful features that exist in the product. 
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Where to Obtain the 
Microsoft and Apple 
Software Glossaries 

 

Obtaining Microsoft 
Glossaries 

Although Microsoft software glossaries in .csv format were previously 

publicly available from Microsoft FTP site, at the time of this publication, 

they are only available though a MSDN subscription available for a fee. 

Each language has a separate .zip file that contains all the individual 

glossaries for the Microsoft products localized into that language. The 

size of each language file can range from 1 to more than 100 megabytes, 

which depends on the number of products that are localized by Microsoft 

into a particular language. 

Obtaining Apple 
Glossaries 

At the time of this publication, the Apple Mac OS X software glossaries 

are available from the following source if you have an Apple ID: 

 http://developer.apple.com/internationalization/downloads/ 

The glossaries for each language are in Macintosh Disk Image format 

(extension .dmg). In order to load the Mac OS glossaries into ApSIC 

Xbench, the .ad or *.lg files contained in these disk images must be 

extracted. To do so, you can use the UltraISO software 

(http://www.ezbsystems.com/ultraiso/index.html). 
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ApSIC Xbench allows you to define Internet links that can be used to 

search the term in the Internet. ApSIC Xbench features a simple 

embedded browser, but by pressing Ctrl+B, you can open your system 

default Internet browser at the page you are currently browsing in ApSIC 

Xbench. 

 

Internet 





 

 85 
 

Searching the Internet 
ApSIC Xbench features an Internet tab that provides an integration path 

with some information and terminology sources available in the Internet. 

The following illustration shows a search in Google done within ApSIC 

Xbench. 

 

ApSIC Xbench has a few predefined shortcuts, but the user can change or 

define new links as required. Defined shortcuts are accessible using one 

of the following methods: 

Move to the Internet tab, select the desired source in the Website field, 

type the search string in the Text to search field and press Enter. 

When ApSIC Xbench is the current application, press Alt+n, where n can 

be any number from 0 to 9. The 0 corresponds to the 10th entry in the list. 

The current term in the Source field of the Project tab or in the Text to 

search field of the Internet tab will be used for the search. The number 

corresponds to the sequence number of the shortcut in Tools->Settings-

>Internet. 

From any Windows application, highlight the term searched, and press 

the key combination Ctrl+Insert followed by Ctrl+Alt+n, where the number 

n must be typed in the numeric keypad with Num Lock set. 
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Defining Internet 
Shortcuts 

Internet shortcuts are defined in Internet->Define Links. The shortcuts 

are very easy to define. Just follow these steps: 

1 Open the list of shortcuts in Internet->Define Links. To create a 

new entry, you just have to move down the keyboard cursor beyond 

the last entry with the arrow keys.  

 

2 Perform a search in the website source that you want to check. For 

example, do a search in Google of a term, for example xbench. 

3 Copy the URL into the clipboard, for example, your URL may look 

like this: 

http://www.google.com/search?hl=en&lr=&ie=UTF-8&q=xbench 

4 Paste the URL into one entry of the window and replace the term you 

searched with a %s as shown below. In future queries that use this 

query string, ApSIC Xbench will replace the %s sequence with the 

search string. 

5 Assign a name to your shortcut by moving the cursor to the Name 

column and typing the name there. This name will appear in the 

Website field of the Internet tab and also in the Internet pull-down 

menu. 

6 If you wish to move the current entry down in the list (this has the 

effect of changing the hotkey number) you can click on the Up and 

Down buttons located on the bottom of the window. 
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If you run into an interesting link when you browse a page using the 

Internet tab of ApSIC Xbench, you can quickly add it to the list of pages 

by using the Internet->Capture URL menu item. 

If you have the tool bar turned on, a number of tool bar buttons appear 

that help you to browse Internet pages. One of these buttons allows you 

to open Internet Explorer with the same page you are looking at. This can 

also be done with Internet ->Open Browser or with the Ctrl+B hotkey. 
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Bugs and Suggestions 
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Reporting Bugs and 
Suggestions 

Your feedback on any errors in the program is most welcome. We are 

also open to suggestions as to how we can improve areas that you find 

confusing.  

Please send your bug report or suggestion to 

http://www.xbench.net/index.php/support/submit-bug. 

Any information you send to us will be kept confidential and it will be 

used solely to resolve the issue. 
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